package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\[\(<](?:(?:yes|YES)[\/,](?:no|NO)|(?:no|NO)[\/,](?:yes|YES))(?:[\/,].*?)?[>\)\]]`)
var str = `This operation bla bla bla...
Confirm this command? [YES,no] - N as default
Confirm this command? [yes,NO] - N as default
Confirm this command? [yes,no] - N as default
Confirm this command? [YES,no,cancel] - N as default
Confirm this command? [yes,NO,cancel] - N as default
Confirm this command? [yes,no,CANCEL] - N as default
Confirm this command? [YES/no] - N as default
Confirm this command? [yes/NO] - N as default
Confirm this command? [yes/no] - N as default
Confirm this command? [YES/no/cancel] - N as default
Confirm this command? [yes/NO/cancel] - N as default
Confirm this command? [yes/no/CANCEL] - N as default
Confirm this command? [no,YES] - Y as default
Confirm this command? [NO,yes] - Y as default
Confirm this command? [no,yes] - Y as default
Confirm this command? [no/YES] - Y as default
Confirm this command? [NO/yes] - Y as default
Confirm this command? [no/yes] - Y as default`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}