$re = '/[\[\(<](?:(?:yes|YES)[\/,](?:no|NO)|(?:no|NO)[\/,](?:yes|YES))(?:[\/,].*?)?[>\)\]]/';
$str = 'This operation bla bla bla...
Confirm this command? [YES,no] - N as default
Confirm this command? [yes,NO] - N as default
Confirm this command? [yes,no] - N as default
Confirm this command? [YES,no,cancel] - N as default
Confirm this command? [yes,NO,cancel] - N as default
Confirm this command? [yes,no,CANCEL] - N as default
Confirm this command? [YES/no] - N as default
Confirm this command? [yes/NO] - N as default
Confirm this command? [yes/no] - N as default
Confirm this command? [YES/no/cancel] - N as default
Confirm this command? [yes/NO/cancel] - N as default
Confirm this command? [yes/no/CANCEL] - N as default
Confirm this command? [no,YES] - Y as default
Confirm this command? [NO,yes] - Y as default
Confirm this command? [no,yes] - Y as default
Confirm this command? [no/YES] - Y as default
Confirm this command? [NO/yes] - Y as default
Confirm this command? [no/yes] - Y as default';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);