#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\[\(<](?:(?:yes|YES)[\/,](?:no|NO)|(?:no|NO)[\/,](?:yes|YES))(?:[\/,].*?)?[>\)\]]"
Local $sString = "This operation bla bla bla..." & @CRLF & _
"" & @CRLF & _
"Confirm this command? [YES,no] - N as default" & @CRLF & _
"Confirm this command? [yes,NO] - N as default" & @CRLF & _
"Confirm this command? [yes,no] - N as default" & @CRLF & _
"" & @CRLF & _
"Confirm this command? [YES,no,cancel] - N as default" & @CRLF & _
"Confirm this command? [yes,NO,cancel] - N as default" & @CRLF & _
"Confirm this command? [yes,no,CANCEL] - N as default" & @CRLF & _
"" & @CRLF & _
"Confirm this command? [YES/no] - N as default" & @CRLF & _
"Confirm this command? [yes/NO] - N as default" & @CRLF & _
"Confirm this command? [yes/no] - N as default" & @CRLF & _
"" & @CRLF & _
"Confirm this command? [YES/no/cancel] - N as default" & @CRLF & _
"Confirm this command? [yes/NO/cancel] - N as default" & @CRLF & _
"Confirm this command? [yes/no/CANCEL] - N as default" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Confirm this command? [no,YES] - Y as default" & @CRLF & _
"Confirm this command? [NO,yes] - Y as default" & @CRLF & _
"Confirm this command? [no,yes] - Y as default" & @CRLF & _
"" & @CRLF & _
"Confirm this command? [no/YES] - Y as default" & @CRLF & _
"Confirm this command? [NO/yes] - Y as default" & @CRLF & _
"Confirm this command? [no/yes] - Y as default"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")