// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\[\(<](?:(?:yes|YES)[\/,](?:no|NO)|(?:no|NO)[\/,](?:yes|YES))(?:[\/,].*?)?[>\)\]]").unwrap();
let string = "This operation bla bla bla...
Confirm this command? [YES,no] - N as default
Confirm this command? [yes,NO] - N as default
Confirm this command? [yes,no] - N as default
Confirm this command? [YES,no,cancel] - N as default
Confirm this command? [yes,NO,cancel] - N as default
Confirm this command? [yes,no,CANCEL] - N as default
Confirm this command? [YES/no] - N as default
Confirm this command? [yes/NO] - N as default
Confirm this command? [yes/no] - N as default
Confirm this command? [YES/no/cancel] - N as default
Confirm this command? [yes/NO/cancel] - N as default
Confirm this command? [yes/no/CANCEL] - N as default
Confirm this command? [no,YES] - Y as default
Confirm this command? [NO,yes] - Y as default
Confirm this command? [no,yes] - Y as default
Confirm this command? [no/YES] - Y as default
Confirm this command? [NO/yes] - Y as default
Confirm this command? [no/yes] - Y as default";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}