# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\[\(<](?:(?:yes|YES)[\/,](?:no|NO)|(?:no|NO)[\/,](?:yes|YES))(?:[\/,].*?)?[>\)\]]"
test_str = ("This operation bla bla bla...\n\n"
"Confirm this command? [YES,no] - N as default\n"
"Confirm this command? [yes,NO] - N as default\n"
"Confirm this command? [yes,no] - N as default\n\n"
"Confirm this command? [YES,no,cancel] - N as default\n"
"Confirm this command? [yes,NO,cancel] - N as default\n"
"Confirm this command? [yes,no,CANCEL] - N as default\n\n"
"Confirm this command? [YES/no] - N as default\n"
"Confirm this command? [yes/NO] - N as default\n"
"Confirm this command? [yes/no] - N as default\n\n"
"Confirm this command? [YES/no/cancel] - N as default\n"
"Confirm this command? [yes/NO/cancel] - N as default\n"
"Confirm this command? [yes/no/CANCEL] - N as default\n\n\n"
"Confirm this command? [no,YES] - Y as default\n"
"Confirm this command? [NO,yes] - Y as default\n"
"Confirm this command? [no,yes] - Y as default\n\n"
"Confirm this command? [no/YES] - Y as default\n"
"Confirm this command? [NO/yes] - Y as default\n"
"Confirm this command? [no/yes] - Y as default")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.