$re = '/(?P<ip>\S*) (?P<firstseperator>-) (?P<userid>\S+|-) (?P<timestamp>\[\S+ \S+) "(?P<URL>\S+|\S+ \S+ [A-Z/0-9.]+)" (?P<http_code>[0-9]+) (?P<guessing_size>[0-9]+) "(?P<endpoint_url>\S+|-)" "(?P<client_and_version>[a-zA-Z/0-9.-]+)/m';
$str = '192.241.202.20 - - [22/Mar/2023:05:31:42 +0000] "SSH-2.0-Go" 400 157 "-" "-"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);