const regex = new RegExp('(?P<ip>\\S*) (?P<firstseperator>-) (?P<userid>\\S+|-) (?P<timestamp>\\[\\S+ \\S+) "(?P<URL>\\S+|\\S+ \\S+ [A-Z/0-9.]+)" (?P<http_code>[0-9]+) (?P<guessing_size>[0-9]+) "(?P<endpoint_url>\\S+|-)" "(?P<client_and_version>[a-zA-Z/0-9.-]+)', 'gm')
const str = `192.241.202.20 - - [22/Mar/2023:05:31:42 +0000] "SSH-2.0-Go" 400 157 "-" "-"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}