package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<ip>\S*) (?P<firstseperator>-) (?P<userid>\S+|-) (?P<timestamp>\[\S+ \S+) "(?P<URL>\S+|\S+ \S+ [A-Z/0-9.]+)" (?P<http_code>[0-9]+) (?P<guessing_size>[0-9]+) "(?P<endpoint_url>\S+|-)" "(?P<client_and_version>[a-zA-Z/0-9.-]+)`)
var str = `192.241.202.20 - - [22/Mar/2023:05:31:42 +0000] "SSH-2.0-Go" 400 157 "-" "-"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}