using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<ip>\S*) (?P<firstseperator>-) (?P<userid>\S+|-) (?P<timestamp>\[\S+ \S+) ""(?P<URL>\S+|\S+ \S+ [A-Z/0-9.]+)"" (?P<http_code>[0-9]+) (?P<guessing_size>[0-9]+) ""(?P<endpoint_url>\S+|-)"" ""(?P<client_and_version>[a-zA-Z/0-9.-]+)";
string input = @"192.241.202.20 - - [22/Mar/2023:05:31:42 +0000] ""SSH-2.0-Go"" 400 157 ""-"" ""-""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}