import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<ip>\\S*) (?P<firstseperator>-) (?P<userid>\\S+|-) (?P<timestamp>\\[\\S+ \\S+) \"(?P<URL>\\S+|\\S+ \\S+ [A-Z/0-9.]+)\" (?P<http_code>[0-9]+) (?P<guessing_size>[0-9]+) \"(?P<endpoint_url>\\S+|-)\" \"(?P<client_and_version>[a-zA-Z/0-9.-]+)";
final String string = "192.241.202.20 - - [22/Mar/2023:05:31:42 +0000] \"SSH-2.0-Go\" 400 157 \"-\" \"-\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}