re = /(<a.*href=(("|')(.*pdf)("|')))/m
str = '<a href="https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf">Un Lienn</a>'
subst = '$1 download'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result