use strict;
my $str = '<a href="https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf">Un Lienn</a>';
my $regex = qr/(<a.*href=(("|')(.*pdf)("|')))/mp;
my $subst = '$1 download';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";