# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a.*href=(("|')(.*pdf)("|')))/$1 download/gm;t' <<< "<a href=\"https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf\">Un Lienn</a>"