import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a.*href=((\"|')(.*pdf)(\"|')))";
final String string = "<a href=\"https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf\">Un Lienn</a>";
final String subst = "$1 download";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}