$re = '/(<a.*href=(("|\')(.*pdf)("|\')))/m';
$str = '<a href="https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf">Un Lienn</a>';
$subst = "$1 download";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;