# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<a.*href=((\"|')(.*pdf)(\"|')))"
test_str = "<a href=\"https://sebastien-lhuillier.com/TCPDF/examples/example_012.pdf\">Un Lienn</a>"
subst = "$1 download"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.