import Foundation
let pattern = #"((\d){21}(,)?){1,4}((\d){21})+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
111111111111111111111
111111111111111111111,
111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111x
111111111111111111111,111111111111111111111000
111111111111111111111,,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)