$re = '/((\d){21}(,)?){1,4}((\d){21})+/';
$str = '111111111111111111111
111111111111111111111,
111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111x
111111111111111111111,111111111111111111111000
111111111111111111111,,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);