#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((\d){21}(,)?){1,4}((\d){21})+"
Local $sString = "111111111111111111111" & @CRLF & _
"111111111111111111111," & @CRLF & _
"111111111111111111111,111111111111111111111" & @CRLF & _
"111111111111111111111,111111111111111111111,111111111111111111111x" & @CRLF & _
"111111111111111111111,111111111111111111111000" & @CRLF & _
"111111111111111111111,,111111111111111111111" & @CRLF & _
"111111111111111111111,111111111111111111111,111111111111111111111," & @CRLF & _
"111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111" & @CRLF & _
"111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")