// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\d){21}(,)?){1,4}((\d){21})+").unwrap();
let string = "111111111111111111111
111111111111111111111,
111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111x
111111111111111111111,111111111111111111111000
111111111111111111111,,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}