import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d){21}(,)?){1,4}((\\d){21})+";
final String string = "111111111111111111111\n"
+ "111111111111111111111,\n"
+ "111111111111111111111,111111111111111111111\n"
+ "111111111111111111111,111111111111111111111,111111111111111111111x\n"
+ "111111111111111111111,111111111111111111111000\n"
+ "111111111111111111111,,111111111111111111111\n"
+ "111111111111111111111,111111111111111111111,111111111111111111111,\n"
+ "111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111\n"
+ "111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}