using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d){21}(,)?){1,4}((\d){21})+";
string input = @"111111111111111111111
111111111111111111111,
111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111x
111111111111111111111,111111111111111111111000
111111111111111111111,,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111
111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111,111111111111111111111";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}