// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\.\-\s").unwrap();
let string = "1.- ahjkfjha
2.- yewuy -uyiu 11 3 nmnf.
3.- oiooq iqu e iquweiu.
10.- wyqu 14- ionc 4 iwqiui q owi 12.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}