import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\.\\-\\s";
final String string = "1.- ahjkfjha\n"
+ "2.- yewuy -uyiu 11 3 nmnf.\n"
+ "3.- oiooq iqu e iquweiu.\n"
+ "10.- wyqu 14- ionc 4 iwqiui q owi 12.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}