using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+\.\-\s";
string input = @"1.- ahjkfjha
2.- yewuy -uyiu 11 3 nmnf.
3.- oiooq iqu e iquweiu.
10.- wyqu 14- ionc 4 iwqiui q owi 12.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}