re = /\d+\.\-\s/m
str = '1.- ahjkfjha
2.- yewuy -uyiu 11 3 nmnf.
3.- oiooq iqu e iquweiu.
10.- wyqu 14- ionc 4 iwqiui q owi 12.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end