#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\.\-\s"
Local $sString = "1.- ahjkfjha" & @CRLF & _
"2.- yewuy -uyiu 11 3 nmnf." & @CRLF & _
"3.- oiooq iqu e iquweiu." & @CRLF & _
"10.- wyqu 14- ionc 4 iwqiui q owi 12."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")