$re = '/\d+\.\-\s/m';
$str = '1.- ahjkfjha
2.- yewuy -uyiu 11 3 nmnf.
3.- oiooq iqu e iquweiu.
10.- wyqu 14- ionc 4 iwqiui q owi 12.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);