import Foundation
let pattern = #"^{{\s?(?:\:{1,2}|!){1}\s?([a-zA-z0-9\.]+)\s?(?:\|\s?(\w+))?\s?}}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{{ :: campaign_statuses.send }}
{{::campaign_statuses.send}}
{{ :: campaign_statuses.send | number }}
{{::campaign_statuses.send|number}}
{{ ! 123123123 | number }}
{{!123123123|number}}
{{ !>>::campaign.date_created | 123123123 | number }}
{{!>>::campaign.date_created123123123|number}}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)