const regex = /^{{\s?(?:\:{1,2}|!){1}\s?([a-zA-z0-9\.]+)\s?(?:\|\s?(\w+))?\s?}}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^{{\\s?(?:\\:{1,2}|!){1}\\s?([a-zA-z0-9\\.]+)\\s?(?:\\|\\s?(\\w+))?\\s?}}$', 'gm')
const str = `{{ :: campaign_statuses.send }}
{{::campaign_statuses.send}}
{{ :: campaign_statuses.send | number }}
{{::campaign_statuses.send|number}}
{{ ! 123123123 | number }}
{{!123123123|number}}
{{ !>>::campaign.date_created | 123123123 | number }}
{{!>>::campaign.date_created123123123|number}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}