// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^{{\s?(?:\:{1,2}|!){1}\s?([a-zA-z0-9\.]+)\s?(?:\|\s?(\w+))?\s?}}$").unwrap();
let string = "{{ :: campaign_statuses.send }}
{{::campaign_statuses.send}}
{{ :: campaign_statuses.send | number }}
{{::campaign_statuses.send|number}}
{{ ! 123123123 | number }}
{{!123123123|number}}
{{ !>>::campaign.date_created | 123123123 | number }}
{{!>>::campaign.date_created123123123|number}}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}