import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{\\{\\s?(?:\\:{1,2}|!){1}\\s?([a-zA-z0-9\\.]+)\\s?(?:\\|\\s?(\\w+))?\\s?\\}\\}$";
final String string = "{{ :: campaign_statuses.send }}\n"
+ "{{::campaign_statuses.send}}\n\n"
+ "{{ :: campaign_statuses.send | number }}\n"
+ "{{::campaign_statuses.send|number}}\n\n\n"
+ "{{ ! 123123123 | number }}\n"
+ "{{!123123123|number}}\n\n"
+ "{{ !>>::campaign.date_created | 123123123 | number }}\n"
+ "{{!>>::campaign.date_created123123123|number}}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}