use strict;
my $str = '{{ :: campaign_statuses.send }}
{{::campaign_statuses.send}}
{{ :: campaign_statuses.send | number }}
{{::campaign_statuses.send|number}}
{{ ! 123123123 | number }}
{{!123123123|number}}
{{ !>>::campaign.date_created | 123123123 | number }}
{{!>>::campaign.date_created123123123|number}}
';
my $regex = qr/^{{\s?(?:\:{1,2}|!){1}\s?([a-zA-z0-9\.]+)\s?(?:\|\s?(\w+))?\s?}}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}