package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^{{\s?(?:\:{1,2}|!){1}\s?([a-zA-z0-9\.]+)\s?(?:\|\s?(\w+))?\s?}}$`)
var str = `{{ :: campaign_statuses.send }}
{{::campaign_statuses.send}}
{{ :: campaign_statuses.send | number }}
{{::campaign_statuses.send|number}}
{{ ! 123123123 | number }}
{{!123123123|number}}
{{ !>>::campaign.date_created | 123123123 | number }}
{{!>>::campaign.date_created123123123|number}}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}