import Foundation
let pattern = #"([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hello there, animal. Banana banana"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3iggedy $1$3$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)