const regex = /([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))', 'g')
const str = `Hello there, animal. Banana banana`;
const subst = `$3iggedy $1$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);