using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))";
string substitution = @"$3iggedy $1$3$4";
string input = @"Hello there, animal. Banana banana";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}