re = /([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))/
str = 'Hello there, animal. Banana banana'
subst = '$3iggedy $1$3$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result