#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))"
Local $sString = "Hello there, animal. Banana banana"
Local $sSubst = "$3iggedy $1$3$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)