use strict;
my $str = 'Hello there, animal. Banana banana';
my $regex = qr/([aeiouAEIOU][a-zA-Z]+)|(([qwrtpsdfghjklzxcvbnmyQWRTPSDFGHJKLZXCVBNMY]+)([a-zA-Z]+))/p;
my $subst = '$3iggedy $1$3$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";