// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)").unwrap();
let string = "# VSCode TODO Tree regex
// NOTE: lorem ipsum
* NOTE: this is a test
/*
* NOTE
*/
- Original Regex:
(//|#|<!--|;|/\\*|^|^\\s*(-|\\d+.))\\s*($TAGS)
- Updated to also find
(\\/\\/|#|<!--|;|\\s?\\*\\s?|^|^\\s*(-|\\d+.))\\s*($TAGS)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}