package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)`)
var str = `# VSCode TODO Tree regex
// NOTE: lorem ipsum
* NOTE: this is a test
/*
* NOTE
*/
- Original Regex:
(//|#|<!--|;|/\*|^|^\s*(-|\d+.))\s*($TAGS)
- Updated to also find
(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*($TAGS)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}