re = /(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)/m
str = '# VSCode TODO Tree regex
// NOTE: lorem ipsum
* NOTE: this is a test
/*
* NOTE
*/
- Original Regex:
(//|#|<!--|;|/\\*|^|^\\s*(-|\\d+.))\\s*($TAGS)
- Updated to also find
(\\/\\/|#|<!--|;|\\s?\\*\\s?|^|^\\s*(-|\\d+.))\\s*($TAGS)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end