const regex = /(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\\/|#|<!--|;|\\s?\\*\\s?|^|^\\s*(-|\\d+.))\\s*(NOTE)', 'gm')
const str = `# VSCode TODO Tree regex
// NOTE: lorem ipsum
* NOTE: this is a test
/*
* NOTE
*/
- Original Regex:
(//|#|<!--|;|/\\*|^|^\\s*(-|\\d+.))\\s*(\$TAGS)
- Updated to also find
(\\/\\/|#|<!--|;|\\s?\\*\\s?|^|^\\s*(-|\\d+.))\\s*(\$TAGS)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}