$re = '/(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)/m';
$str = '# VSCode TODO Tree regex
// NOTE: lorem ipsum
* NOTE: this is a test
/*
* NOTE
*/
- Original Regex:
(//|#|<!--|;|/\\*|^|^\\s*(-|\\d+.))\\s*($TAGS)
- Updated to also find
(\\/\\/|#|<!--|;|\\s?\\*\\s?|^|^\\s*(-|\\d+.))\\s*($TAGS)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);