using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*(NOTE)";
string input = @"# VSCode TODO Tree regex
// NOTE: lorem ipsum
* NOTE: this is a test
/*
* NOTE
*/
- Original Regex:
(//|#|<!--|;|/\*|^|^\s*(-|\d+.))\s*($TAGS)
- Updated to also find
(\/\/|#|<!--|;|\s?\*\s?|^|^\s*(-|\d+.))\s*($TAGS)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}