// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(VI[0-9]{4}(?:BV)?(?:\d{2})?(D|H|MIN|MAX)?)+$").unwrap();
let string = "6789
VI2111
VI2122
VI2122MIN
VI2122MAX
VI2122MUN
VI210021
VI210021D
VI210021H
VI210021X
VI2100BVMIN
VI2100BVMAX
VI2100
VI21001";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}