import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(VI[0-9]{4}(?:BV)?(?:\\d{2})?(D|H|MIN|MAX)?)+$";
final String string = "6789\n"
+ "VI2111\n"
+ "VI2122\n"
+ "VI2122MIN\n"
+ "VI2122MAX\n"
+ "VI2122MUN\n"
+ "VI210021\n"
+ "VI210021D\n"
+ "VI210021H\n"
+ "VI210021X\n"
+ "VI2100BVMIN\n"
+ "VI2100BVMAX\n"
+ "VI2100\n"
+ "VI21001";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}