#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(VI[0-9]{4}(?:BV)?(?:\d{2})?(D|H|MIN|MAX)?)+$"
Local $sString = "6789" & @CRLF & _
"VI2111" & @CRLF & _
"VI2122" & @CRLF & _
"VI2122MIN" & @CRLF & _
"VI2122MAX" & @CRLF & _
"VI2122MUN" & @CRLF & _
"VI210021" & @CRLF & _
"VI210021D" & @CRLF & _
"VI210021H" & @CRLF & _
"VI210021X" & @CRLF & _
"VI2100BVMIN" & @CRLF & _
"VI2100BVMAX" & @CRLF & _
"VI2100" & @CRLF & _
"VI21001"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")