package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(VI[0-9]{4}(?:BV)?(?:\d{2})?(D|H|MIN|MAX)?)+$`)
var str = `6789
VI2111
VI2122
VI2122MIN
VI2122MAX
VI2122MUN
VI210021
VI210021D
VI210021H
VI210021X
VI2100BVMIN
VI2100BVMAX
VI2100
VI21001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}